Experiencing degraded service

Incident Report for Swell

Resolved

We have upscaled our infrastructure, performance level restored, we are continuing monitoring
Posted May 08, 2026 - 17:27 PDT

Identified

We are currently experiencing a large increase in traffic, which may cause slower response times for some users.
Posted May 08, 2026 - 13:24 PDT

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted May 08, 2026 - 13:00 PDT
This incident affected: Frontend API.