Experiencing degraded service

Incident Report for Swell

Resolved

This incident has been resolved.
Posted May 06, 2024 - 14:56 PDT

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted May 06, 2024 - 10:25 PDT