Experiencing degraded service

Incident Report for Swell

Resolved

A fix has been implemented, and system performance has recovered from the degraded state. Our team will continue to monitor to ensure stability and address any further issues.
Posted Feb 26, 2026 - 13:50 PST

Identified

We have identified posible root cause of the DB connection issue, working on fix
Posted Feb 26, 2026 - 09:33 PST

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted Feb 26, 2026 - 04:16 PST
This incident affected: Backend API.