Monitoring AWS Outage

Incident Report for Swell

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:56 PDT

Monitoring

We are closely monitoring the ongoing AWS outage that began earlier today. While some of Swell’s services are hosted on AWS, we are not seeing any impact at this time. We will continue to monitor the situation and provide updates if any issues arise.

If you experience any issues, please contact us via email at support@swell.is, as our in-app chat service (Intercom) appears to be affected by the ongoing AWS outage.
Posted Oct 20, 2025 - 08:56 PDT