Degraded performance
Incident Report for Swell
Resolved
Our systems were affected due to an outage related to our DNS provider.
Posted Mar 24, 2023 - 10:54 PDT
Monitoring
We are still investigating the cause of the interruption, but services have stabilized. We will continue to monitor.
Posted Mar 24, 2023 - 09:11 PDT
Investigating
We are currently investigating an issue causing degraded performance affecting the frontend API and our CDN
Posted Mar 24, 2023 - 08:42 PDT
This incident affected: Frontend API and CDN.