Experiencing degraded service

Incident Report for Swell

Resolved

The issue appears to be resolved, and systems are currently operating as expected. Our team will continue to monitor closely to ensure stability
Posted Mar 20, 2026 - 12:29 PDT

Identified

We are currently aware of an issue with a third-party service (MongoDB Atlas) used within our infrastructure, which is experiencing degraded performance, affecting connectivity to our database systems.

Our team is actively monitoring the situation and assessing any impact. We will provide updates as more information becomes available.
Posted Mar 20, 2026 - 09:16 PDT

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted Mar 20, 2026 - 09:07 PDT