Experiencing degraded service

Incident Report for Swell

Resolved

It was false-positive alarm from our logging system
Posted Apr 10, 2026 - 23:17 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 23:05 PDT

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted Apr 10, 2026 - 22:38 PDT
This incident affected: Backend API.