Experiencing degraded service

Incident Report for Swell

Resolved

We have upscaled our database to handle larger amount of data
Posted Feb 26, 2026 - 01:57 PST

Identified

We are upscaling our cloud DB to prevent this issue in future
Posted Feb 26, 2026 - 01:17 PST

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted Feb 26, 2026 - 00:57 PST
This incident affected: Backend API.