Experiencing degraded service

Incident Report for Swell

Resolved

Our backend was not able to connect to cloud database provider, it was shortly resolved
Posted Feb 20, 2026 - 03:39 PST

Investigating

The Swell platform is currently experiencing degraded performance. Our team is investigating the issue.
Posted Feb 19, 2026 - 23:20 PST
This incident affected: Backend API.